The maintenance has now been complete. We are currently monitoring and verifying the changes.
Posted Jul 09, 2025 - 09:14 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 09, 2025 - 09:00 UTC
Scheduled
Scheduled Maintenance Notification
We will be performing scheduled maintenance on our LIVE environment to optimise database storage and performance. During this time, there may be a brief disruption in the availability of some data services.
Maintenance Window:
Date: Wednesday, 9th July 2025 Time: 10:00 AM BST Duration: Up to 1 hour
Impact:
During the maintenance window, we do not expect any disruption, however MET data may be temporarily absent from the Planning Portal and flight briefings taken during the maintenance window on the LIVE environment. This activity is expected to last only a few minutes.
Posted Jul 02, 2025 - 14:42 UTC
This scheduled maintenance affected: Ground portal, Flight Plan processing, and EFB integration.